const regex = new RegExp('^\\(01\\)(?P<gtin14>[0-9]{14})\\(21\\)(?P<serial_number>[0-9]{1,20})\\(17\\)(?P<expiration_date>[0-9]{6})\\(10\\)(?P<lot>[a-zA-Z0-9]{1,20})', 'gm')
const str = `(01)03555555345345(21)234390(17)201231(10)22654`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}