import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(01\\)(?P<gtin14>[0-9]{14})\\(21\\)(?P<serial_number>[0-9]{1,20})\\(17\\)(?P<expiration_date>[0-9]{6})\\(10\\)(?P<lot>[a-zA-Z0-9]{1,20})";
final String string = "(01)03555555345345(21)234390(17)201231(10)22654";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}