re = /(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]/
str = '12:59:23
01:01:01
11:11:11
23:59:59
24:15:65
99:99:14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end