$re = '/(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]/';
$str = '12:59:23
01:01:01
11:11:11
23:59:59
24:15:65
99:99:14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);