const regex = /(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]', 'g')
const str = `12:59:23
01:01:01
11:11:11
23:59:59
24:15:65
99:99:14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}