package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]`)
var str = `12:59:23
01:01:01
11:11:11
23:59:59
24:15:65
99:99:14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}