import Foundation
let pattern = #"(\S+) = .*VOS_Malloc\(\S+, .*\);.*memset_s\s*\([^,]*\1[^,]*, ([^,]+), [^,]+, ([^,]+)\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length, 0, tmp_length);
nRet = memcpy_s ((VOID *)(pNewBuf), (VOS_UINT32)tmp_length, (VOID *)(tmp_buf), (VOS_UINT32)tmp_offset);
VOS_DBGASSERT(nRet == VOS_OK);
(VOID)VOS_Free(tmp_buf);
pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length * 3, 0, tmp_length);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)