use strict;
my $str = ' pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length, 0, tmp_length);
nRet = memcpy_s ((VOID *)(pNewBuf), (VOS_UINT32)tmp_length, (VOID *)(tmp_buf), (VOS_UINT32)tmp_offset);
VOS_DBGASSERT(nRet == VOS_OK);
(VOID)VOS_Free(tmp_buf);
pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length * 3, 0, tmp_length);
';
my $regex = qr/(\S+) = .*VOS_Malloc\(\S+, .*\);.*memset_s\s*\([^,]*\1[^,]*, ([^,]+), [^,]+, ([^,]+)\);/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}