re = /(\S+) = .*VOS_Malloc\(\S+, .*\);.*memset_s\s*\([^,]*\1[^,]*, ([^,]+), [^,]+, ([^,]+)\);/m
str = ' pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length, 0, tmp_length);
nRet = memcpy_s ((VOID *)(pNewBuf), (VOS_UINT32)tmp_length, (VOID *)(tmp_buf), (VOS_UINT32)tmp_offset);
VOS_DBGASSERT(nRet == VOS_OK);
(VOID)VOS_Free(tmp_buf);
pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length * 3, 0, tmp_length);
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end