using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+) = .*VOS_Malloc\(\S+, .*\);.*memset_s\s*\([^,]*\1[^,]*, ([^,]+), [^,]+, ([^,]+)\);";
string input = @" pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length, 0, tmp_length);
nRet = memcpy_s ((VOID *)(pNewBuf), (VOS_UINT32)tmp_length, (VOID *)(tmp_buf), (VOS_UINT32)tmp_offset);
VOS_DBGASSERT(nRet == VOS_OK);
(VOID)VOS_Free(tmp_buf);
pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);
if (NULL == pNewBuf) {
(VOID)VOS_Free(tmp_buf);
*buf = NULL;
return VOS_ERR;
}
(VOID)memset_s ((CHAR *)(pNewBuf), tmp_length * 3, 0, tmp_length);
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}