import Foundation
let pattern = #"(?<=\/)[\w\-.]+(?=(\?|(\s*)$|(\/)$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.tokopedia.com/laris88/tempat-bumbu-dapur-4-sekat-joyfeel-1047-seasoning-storage-merah-muda
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali?whid=0
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali
https://gql.tokopedia.com/tokopedia.com/
https://gql.tokopedia.com/ceriasmart/
https://gql.tokopedia.com/22ceria.-smart/
tokopedia\.com/([^/]+[\w])
todo
i want grab only "gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali" without end character '?'
tokopedia\.com/[^/]*[\w\/](.*)|[?!\?]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)