using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/)[\w\-.]+(?=(\?|(\s*)$|(\/)$))";
string input = @"https://www.tokopedia.com/laris88/tempat-bumbu-dapur-4-sekat-joyfeel-1047-seasoning-storage-merah-muda
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali?whid=0
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali
https://gql.tokopedia.com/tokopedia.com/
https://gql.tokopedia.com/ceriasmart/
https://gql.tokopedia.com/22ceria.-smart/
tokopedia\.com/([^/]+[\w])
todo
i want grab only ""gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali"" without end character '?'
tokopedia\.com/[^/]*[\w\/](.*)|[?!\?]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}