# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\/)[\w\-.]+(?=(\?|(\s*)$|(\/)$))"
test_str = ("https://www.tokopedia.com/laris88/tempat-bumbu-dapur-4-sekat-joyfeel-1047-seasoning-storage-merah-muda\n"
"https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali?whid=0\n"
"https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali\n"
"https://gql.tokopedia.com/tokopedia.com/\n"
"https://gql.tokopedia.com/ceriasmart/\n"
"https://gql.tokopedia.com/22ceria.-smart/\n\n"
"tokopedia\\.com/([^/]+[\\w])\n\n\n\n"
"todo\n"
"i want grab only \"gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali\" without end character '?'\n\n"
"tokopedia\\.com/[^/]*[\\w\\/](.*)|[?!\\?]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.