re = /[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+/m
str = 'Иванов Иван Иванович
Иван
Иванов Иван'
# Print the match result
str.match(re) do |match|
puts match.to_s
end