import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-яА-ЯЁё]+\\s+[a-яА-ЯЁё]+\\s+[a-яА-ЯЁё]+";
final String string = "Иванов Иван Иванович\n"
+ "Иван\n"
+ "Иванов Иван";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}