package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+`)
var str = `Иванов Иван Иванович
Иван
Иванов Иван`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}