$re = '/[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+\s+[a-яА-ЯЁё]+/m';
$str = 'Иванов Иван Иванович
Иван
Иванов Иван';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);