re = /(?<=\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\-(他|自)動詞)?(?=\]\|は)/m
str = '目指す[目指す]|は[は] 国家[国家]|資格[資格]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end