use strict;
my $str = '目指す[目指す]|は[は] 国家[国家]|資格[資格]';
my $regex = qr/(?<=\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\-(他|自)動詞)?(?=\]\| は)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}