import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\\-(他|自)動詞)?(?=\\]\\|は)";
final String string = "目指す[目指す]|は[は] 国家[国家]|資格[資格]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}