# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)"
test_str = "Audit Success,16/03/2017 12:01:08,Microsoft-Windows-Eventlog,1107,Event processing,The event logging service encountered an error while processing an incoming event from publisher and trying to process the metadata for it."
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.