import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\\d+),(?P<category>.*),(?P<event_message>.*)";
final String string = "Audit Success,16/03/2017 12:01:08,Microsoft-Windows-Eventlog,1107,Event processing,The event logging service encountered an error while processing an incoming event from publisher and trying to process the metadata for it.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}