package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)`)
var str = `Audit Success,16/03/2017 12:01:08,Microsoft-Windows-Eventlog,1107,Event processing,The event logging service encountered an error while processing an incoming event from publisher and trying to process the metadata for it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}