$re = '/Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)/';
$str = 'Audit Success,16/03/2017 12:01:08,Microsoft-Windows-Eventlog,1107,Event processing,The event logging service encountered an error while processing an incoming event from publisher and trying to process the metadata for it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);