// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n\s*([\w\\]*)[\s\/]*([\w\s]*).*^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w\s]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\n([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)").unwrap();
let string = "
Name Mount Point Description
---- ----------- -----------
ETC$ /etc Remote Administration
BUILTIN\\Administrators / Full Control
C$ / Remote Administration
BUILTIN\\Administrators / Full Control
HYDROQC\\APPL-NETAPP-ADMIN / Full Control
^(ETC\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}