$re = '/^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n\s*([\w\\\\]*)[\s\/]*([\w\s]*).*^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\\\]*)[\s\/]*([\w\s]*)\n\s*([\w\/\-\\\\]*)[\s\/]*([\w\/\-\\\\ ]*)\n([\s\^\(\w\\\\\$\)\[\]\*\/\-\?\:]*)/mi';
$str = '
Name Mount Point Description
---- ----------- -----------
ETC$ /etc Remote Administration
BUILTIN\\Administrators / Full Control
C$ / Remote Administration
BUILTIN\\Administrators / Full Control
HYDROQC\\APPL-NETAPP-ADMIN / Full Control
^(ETC\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);