package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n\s*([\w\\]*)[\s\/]*([\w\s]*).*^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w\s]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\n([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)`)
var str = `
Name Mount Point Description
---- ----------- -----------
ETC$ /etc Remote Administration
BUILTIN\Administrators / Full Control
C$ / Remote Administration
BUILTIN\Administrators / Full Control
HYDROQC\APPL-NETAPP-ADMIN / Full Control
^(ETC\$)[\s]*(\/[\w]*)[\s]*([a-zA-Z\s]*)\n\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n^(C\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n(?:\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}