const regex = /^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n\s*([\w\\]*)[\s\/]*([\w\s]*).*^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w\s]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\n([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w*\\$)[\\s]*(\\\/[\\w]*)[\\s]*([\\w\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\\/]*([\\w\\s]*).*^(\\w*\\$)\\s*([\\w\\\/\\-]*)\\s*([\\w \\-\\\/]*)[\\n\\s]*([\\w\\\/\\-\\\\]*)[\\s\\\/]*([\\w\\s]*)\\n\\s*([\\w\\\/\\-\\\\]*)[\\s\\\/]*([\\w\\\/\\-\\\\ ]*)\\n([\\s\\^\\(\\w\\\\\\$\\)\\[\\]\\*\\\/\\-\\?\\:]*)', 'gmi')
const str = `
Name Mount Point Description
---- ----------- -----------
ETC\$ /etc Remote Administration
BUILTIN\\Administrators / Full Control
C\$ / Remote Administration
BUILTIN\\Administrators / Full Control
HYDROQC\\APPL-NETAPP-ADMIN / Full Control
^(ETC\\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}