$re = '/(^[A-Za-z]|(?<=[^\w])[A-Za-z]|(?<![A-Z])[A-Z])/';
$str = 'PHP: Hypertext Preprocessor
Portable Network Graphics
Ruby on Rails
HyperText Markup Language
First In, First Out
Complementary metal-oxide semiconductor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);