using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Za-z]|(?<=[^\w])[A-Za-z]|(?<![A-Z])[A-Z])";
string input = @"PHP: Hypertext Preprocessor
Portable Network Graphics
Ruby on Rails
HyperText Markup Language
First In, First Out
Complementary metal-oxide semiconductor";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}