#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^[A-Za-z]|(?<=[^\w])[A-Za-z]|(?<![A-Z])[A-Z])"
Local $sString = "PHP: Hypertext Preprocessor" & @CRLF & _
"Portable Network Graphics" & @CRLF & _
"Ruby on Rails" & @CRLF & _
"HyperText Markup Language" & @CRLF & _
"First In, First Out" & @CRLF & _
"Complementary metal-oxide semiconductor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")