const regex = new RegExp('(^[A-Za-z]|(?<=[^\\w])[A-Za-z]|(?<![A-Z])[A-Z])', 'g')
const str = `PHP: Hypertext Preprocessor
Portable Network Graphics
Ruby on Rails
HyperText Markup Language
First In, First Out
Complementary metal-oxide semiconductor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}