// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]{0,}[x| |\-]{0,}[[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]?[ |\-|\/|\.]?]?[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]+[ |\-]*(g|lb|pound|kg)[s]?[^a-z]*").unwrap();
let string = "145 pounds of bread";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}