$re = '/[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]{0,}[x| |\-]{0,}[[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]?[ |\-|\/|\.]?]?[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]+[ |\-]*(g|lb|pound|kg)[s]?[^a-z]*/i';
$str = '145 pounds of bread';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);