const regex = /[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]{0,}[x| |\-]{0,}[[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]?[ |\-|\/|\.]?]?[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]+[ |\-]*(g|lb|pound|kg)[s]?[^a-z]*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]{0,}[x| |\\-]{0,}[[\\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]?[ |\\-|\\\/|\\.]?]?[\\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]+[ |\\-]*(g|lb|pound|kg)[s]?[^a-z]*', 'i')
const str = `145 pounds of bread`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}