use strict;
my $str = '145 pounds of bread';
my $regex = qr/[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]{0,}[x| |\-]{0,}[[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]?[ |\-|\/|\.]?]?[\d|½|⅓|¼|⅔|¾|⅛|⅜|⅝|⅞]+[ |\-]*(g|lb|pound|kg)[s]?[^a-z]*/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}