re = /^(0|\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}/mi
str = '0682928919
0501468879
0715448664
01656565656656
03 02 021 02
+33682928919
06.82.92.89.19
06 82 92 89 19
+336.82.92.89.19
+33 682928919'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end