# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0|\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}"
test_str = ("0682928919\n"
"0501468879\n"
"0715448664\n"
"01656565656656\n"
"03 02 021 02\n"
"+33682928919\n"
"06.82.92.89.19\n"
"06 82 92 89 19\n"
"+336.82.92.89.19\n"
"+33 682928919")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.