import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|\\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}";
final String string = "0682928919\n"
+ "0501468879\n"
+ "0715448664\n"
+ "01656565656656\n"
+ "03 02 021 02\n"
+ "+33682928919\n"
+ "06.82.92.89.19\n"
+ "06 82 92 89 19\n"
+ "+336.82.92.89.19\n"
+ "+33 682928919";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}