const regex = /^(0|\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0|\\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}', 'gmi')
const str = `0682928919
0501468879
0715448664
01656565656656
03 02 021 02
+33682928919
06.82.92.89.19
06 82 92 89 19
+336.82.92.89.19
+33 682928919`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}