re = /IO::Memory(O|I)Channel(|32)([\s]|::|&[\s])/m
str = ' GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);
BinIProtocol.hpp
BinOProtocol.hpp
InputBuffer.hpp
OutputBuffer.hpp
IChannelAdapter.hpp
OChannelAdapter.hpp
MemoryIChannel.hpp
MemoryIChannel32.hpp
MemoryOChannel.hpp
MemoryOChannel32.hpp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end