use strict;
my $str = ' GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);
BinIProtocol.hpp
BinOProtocol.hpp
InputBuffer.hpp
OutputBuffer.hpp
IChannelAdapter.hpp
OChannelAdapter.hpp
MemoryIChannel.hpp
MemoryIChannel32.hpp
MemoryOChannel.hpp
MemoryOChannel32.hpp';
my $regex = qr/IO::Memory(O|I)Channel(|32)([\s]|::|&[\s])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}