import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "IO::Memory(O|I)Channel(|32)([\\s]|::|&[\\s])";
final String string = " GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);\n\n\n\n"
+ " BinIProtocol.hpp\n"
+ " BinOProtocol.hpp\n"
+ " InputBuffer.hpp\n"
+ " OutputBuffer.hpp\n"
+ " IChannelAdapter.hpp\n"
+ " OChannelAdapter.hpp\n"
+ " MemoryIChannel.hpp\n"
+ " MemoryIChannel32.hpp\n"
+ " MemoryOChannel.hpp\n"
+ " MemoryOChannel32.hpp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}