package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)IO::Memory(O|I)Channel(|32)([\s]|::|&[\s])`)
var str = ` GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);
BinIProtocol.hpp
BinOProtocol.hpp
InputBuffer.hpp
OutputBuffer.hpp
IChannelAdapter.hpp
OChannelAdapter.hpp
MemoryIChannel.hpp
MemoryIChannel32.hpp
MemoryOChannel.hpp
MemoryOChannel32.hpp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}