import Foundation
let pattern = #"( \[.*\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Portuguese B (H13) [1 Teacher & 0 Subject Heads]
Russian A l&l (S12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H13) [1 Teacher & 0 Subject Heads]
Russian A lit. (S12) [1 Teacher & 0 Subject Heads]
Russian B (H12) [1 Teacher & 0 Subject Heads]
Russian B (H13) [1 Teacher & 0 Subject Heads]
Russian B (S12) [1 Teacher & 0 Subject Heads]
Russian B (S13) [1 Teacher & 0 Subject Heads]
Physical education [12 Teachers & 0 Subject Heads]
Physical education (12) [7 Teachers & 0 Subject Heads]
Sports science [12 Teachers & 0 Subject Heads]
Sports science (H12) [4 Teachers & 0 Subject Heads]
Sports science (H13) [4 Teachers & 0 Subject Heads]
Sports science (S12) [12 Teachers & 0 Subject Heads]
Sports science (S13) [13 Teachers & 0 Subject Heads]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)