re = /( \[.*\])/
str = 'Portuguese B (H13) [1 Teacher & 0 Subject Heads]
Russian A l&l (S12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H13) [1 Teacher & 0 Subject Heads]
Russian A lit. (S12) [1 Teacher & 0 Subject Heads]
Russian B (H12) [1 Teacher & 0 Subject Heads]
Russian B (H13) [1 Teacher & 0 Subject Heads]
Russian B (S12) [1 Teacher & 0 Subject Heads]
Russian B (S13) [1 Teacher & 0 Subject Heads]
Physical education [12 Teachers & 0 Subject Heads]
Physical education (12) [7 Teachers & 0 Subject Heads]
Sports science [12 Teachers & 0 Subject Heads]
Sports science (H12) [4 Teachers & 0 Subject Heads]
Sports science (H13) [4 Teachers & 0 Subject Heads]
Sports science (S12) [12 Teachers & 0 Subject Heads]
Sports science (S13) [13 Teachers & 0 Subject Heads]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end