#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "( \[.*\])"
Local $sString = "Portuguese B (H13) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian A l&l (S12) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian A lit. (H12) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian A lit. (H13) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian A lit. (S12) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian B (H12) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian B (H13) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian B (S12) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"Russian B (S13) [1 Teacher & 0 Subject Heads]" & @CRLF & _
"" & @CRLF & _
"Physical education [12 Teachers & 0 Subject Heads]" & @CRLF & _
"Physical education (12) [7 Teachers & 0 Subject Heads]" & @CRLF & _
"Sports science [12 Teachers & 0 Subject Heads]" & @CRLF & _
"Sports science (H12) [4 Teachers & 0 Subject Heads]" & @CRLF & _
"Sports science (H13) [4 Teachers & 0 Subject Heads]" & @CRLF & _
"Sports science (S12) [12 Teachers & 0 Subject Heads]" & @CRLF & _
"Sports science (S13) [13 Teachers & 0 Subject Heads]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")