use strict;
my $str = 'Portuguese B (H13) [1 Teacher & 0 Subject Heads]
Russian A l&l (S12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H12) [1 Teacher & 0 Subject Heads]
Russian A lit. (H13) [1 Teacher & 0 Subject Heads]
Russian A lit. (S12) [1 Teacher & 0 Subject Heads]
Russian B (H12) [1 Teacher & 0 Subject Heads]
Russian B (H13) [1 Teacher & 0 Subject Heads]
Russian B (S12) [1 Teacher & 0 Subject Heads]
Russian B (S13) [1 Teacher & 0 Subject Heads]
Physical education [12 Teachers & 0 Subject Heads]
Physical education (12) [7 Teachers & 0 Subject Heads]
Sports science [12 Teachers & 0 Subject Heads]
Sports science (H12) [4 Teachers & 0 Subject Heads]
Sports science (H13) [4 Teachers & 0 Subject Heads]
Sports science (S12) [12 Teachers & 0 Subject Heads]
Sports science (S13) [13 Teachers & 0 Subject Heads]';
my $regex = qr/( \[.*\])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}