$re = '/[^0-9.,]/m';
$str = '(626.123*) 34a2- 4387,222222)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;