package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9.,]`)
var str = `(626.123*) 34a2- 4387,222222)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}